SP140 Throttle no longer able to arm

Hi, my throttle no longer is reacting to the button press/tap, and is unable to arm. I can hear the mechanical click and haven’t tried disassembling it yet, I also connected it with USB OK, and even reflashed it with the same firmware (5.7, non-PI). No change. I thought it was maybe to battery being too low, I charged from 55% to 62% but no change. Is there a cutoff voltage that prevents arming?

More details: I had a routine flight, armed the throttle with 2 taps, flew for 14 minutes on the smaller battery, disarmed the throttle before landing, and landed OK. I haven’t tried re-arming again that evening, but the next day I plugged it in again and it now displays everything correctly but won’t react to button taps.

The controller keeps beeping single beeps every 10 seconds or so, I thought it used to have two tone beep before (high, low), but my recording shows that before flight it was beeping the same way.

UPDATE: I also did disconnect and reconnect both of the 4-pin cables on the controller a few times, no change.
And the throttle display shows “BATTERY ERROR” very briefly on start, but I think I had noticed that before, it’s split-second on boot.

Any ideas?

A couple things

  • the latest firmwares have changed the default arming sequence for the buttons to a tap then hold.
  • if you don’t see the controller screen update when arming then it’s something happening on the controller itself and not the motor/ESC. It’s typical for the ESC to beep periodically when it’s on but at 0% throttle
1 Like

Good to know about the change, I’m guessing the tap and hold is introduced with 6.0 that is not available for my older throttle yet, but I will try it when I get home. I like the idea. Is there a simple way to diagnose the throttle button/potentiometer similar to gamepads at Hardware Tester (it shows animated buttons and stick values in real time)?
Or perhaps we could show the status on the throttle display, even when it’s disarmed, just a tiny 1-2 pixel dot for the button and 1 pixel width line animated for the throttle status…

1 Like

Update: I took it apart and measured the connectivity in the leads underneath the circuit board (after ungluing the screen). Didn’t work, as if the microswitch was broken inside. I then tried the two metal dots in the side of the microswitch and they worked. I kept trying the underside leads and attempted to push the switch in, didn’t seem to budge, well soldered mounts, but it started to work. I did dozens of dry tests more, and it works just like before (I am able to 2-tap almost exactly 50% of time in 30 tests, after failing 100% of time in similar number of tests; can’t wait for the new tap and hold mode).


I didn’t take a good photo but I think the 2 dots (or rather short dashes) I tested successfully against are on the side facing the camera.