Replacement Parts

It seems that I’m not the only one who has experienced problems with the Batch 4 throttle.

Mine worked fine at first but, during my hang test, it was very difficult to engage. Then, when I attempted my 1st actual flight, the unit did not respond at all. The entire flight plan had to be aborted. I disassembled the controller but, I didn’t find a reset button as mentioned in other posts. My question is, is there a reset button on the batch 4 throttle or, was it phased out?

If I have to buy a completely new throttle, I will. But the question is, is there one available?

Any help would be greatly appreciated,
MAO

Batch 4 doesnt have the reset button internally but it can be added.

DM me and I can try to help figure out the actual issue

I am also having problems with the throttle. I can’t arm the unit any more. The LCD display stopped working. I opened the throttle casing and looked at the circuit board. The red LED is on but buttons are not functioning. Is there a way I can troubleshoot this? or do I need a new throttle. Is so how can I order one?

I too, opened the Throttle casing. Even with a magnifying glass, nothing was obviously broken. I did see some discoloration around the top LED. But, I wouldn’t know how to correct that, even if it was the problem. Through DM I did get a web address for a replacement part. Unfortunately, that only placed a “Back Order”. But, at least I have something to look forward to. Too bad though, I’m missing great flying days here in North Texas. Anyway, the site is openppg.com/shop/paramotors/replacement-parts/throttle-controller/
Good Luck to You

Thank you. Ordered a replacement throttle. Were you able to reset your throttle?

No luck on a reset. I did re-solder a wire that appeared disconnected but to no avail. For now, I can only practice my ground handling and wait for the replacement throttle to get here.

@omao Did you receive your replacement throttle? I am still waiting on mine.

Hey guys thanks for being patient. Obviously with the COVID situation we’ve seen lots shipping delays.
We did get more controller and hub boards in and I am testing them now.
Looking good so far so upgrades and replacements for those should be shipping in the next few days.

Controllers and hubs pcbs shipped out today, so if you need one we can ship them out when you order.

2 Likes

Hey Men, I received my controller yesterday. I hooked it up but, I am still not getting anything on the display nor am I able to arm the unit. Is the new controller still armed by a double click on the top button or, did that change?

Is there anything else anyone can think that might be wrong?

When I got my batch 4 kit four month ago and I was ready to test the motors, I was not getting any display on my controller, so I checked the voltage on the DC to DC converter that takes the 60v from the batteries and steps it down to 5v to run the hub PCB and the controller and my voltage was around 3.5 volts, so using my voltmeter and a small screw driver I adjusted the voltage to 5 volts and bingo my controller started working.

4 Likes

Wow! Thanks for the tip. It’s a bit technologically over my head but, I will start reading up on that right away. Thanks again

Do you have any hubs left? A couple of chips on mine fried on Friday. Seems the issue was that the DC-DC power supply for the hub has gone and allowed full battery voltage through to the hub which it obviously can’t handle. If you’ve a Batch 4 hub available I’d really appreciate it. Can power it with a separate battery rather than the DC-DC converter if those are a problemo.
Fried chips


Cause of fried chips. Testing the power supply and the output side is showing the full input voltage.

We actually have built in overvoltage protection @glydrfreak added for the latest batch 6 hubs.
Do you know if the controller is still functional?

1 Like

Nice! Mine is batch 4
As I recall the controller readout was blank but the arming led was lit. It wasn’t responding but I assume that could be due to the fried main board. How can I test it?

I had the same problem in January…
Did you had a functionning system and at once the DC to DC converter stoped functionning? Or was it like me on the first attempt to run-up?

Regarding the controler I was told to unplug it totally and to power it via the micro-usb at the botom, and it should power up. (did not in my case, was a batch4, spare parts should be on their way as we speek…)

Nice to have an overvoltage protection in the new hubs!! Very good idea! May I ask if it is a fuse-like system, with a replacement fuse in case of overvoltage or is it all electronic?

1 Like

Its an all-digital system so you can over-volt it up to ~80v as many times as you want (but please don’t do this just for fun :slight_smile: ).
Heres a link to the datasheet for that part if you’re curious

The system had been working for over 2 dozen flights this spring. It was - or seemed to be - functioning well when I plugged in and setup last Friday. I was clipped in and ready to take off. I was waiting for a gust cycle with the system disarmed (motors beeping). Then I heard a ‘pop’ noise and smelled the chips burning a few seconds later. The motors were still beeping but the controller did not respond and the readout was blank. I switched off, unclipped, and unplugged the batteries.

Zach can you send me a new mainboard and DC-DC converter? I’ve sent you my address by direct message.

Just now I plugged it into a micro-usb power adapter but there was no response. I plugged it into a USB charging port on my laptop and the laptop reported that the device was requesting more power than the port could provide. Since there was a response on the computer I know my USB cable was connected.

Seems maybe not.