New ESC and Controller firmware

APD have a new firmware that might work better. Unfortunately, the throttle controller does not support it. So Paul & Co have to fix a new firmware for the throttle before we can update to new ESC firmware.
CEll replacement is time consuming as you need to go through all 11 cells(charge/discharge to see which one lacks the capacity) to find the bad guys.

Which firmware are you referring to? The controller firmware from OpenPPG is compatible with the latest ESC firmware as far as I know

This was on Sept 2022, when I wanted to flash with APD v2 firmware. back then the throttle(5.6R) did not give me any telemtry reading back. So I switched back to V1. Even back then V1 was not accessible on APD site so guys was kind enough to send me the V1 file manually.
Are you sure now that latest V2 esc firmware works with PPG controller(latest firmware)?
Got this from APD:
"There are additional stability improvements to V2, so we would prefer if we could get you running on that. " - APD

1 Like

Ah I see. A few versions of the controller firmware have been released since then. 5.8 has support for the new ESC telemetry Releases · openppg/eppg-controller · GitHub
Its also available in the config tool. Let me know if you run into any issues after upgrading both


Thats great,
One think I am missing is the speed on LCD, is it possible to implement?

What do you mean by speed?

Speed over ground. Also I noticed that controller voltage differs by a few volts compared to the pack voltage, is that something that can be fixed?

Speed over the ground would need to come from a GPS. The easiest way to get that is just by pulling out your smartphone and using a GPS speed app to get that.
For a more integrated solution, I think we could integrate a GPS module like the one below which could give you the GPS data to then display on the controller screen.

It would require a modified controller PCB for the new inputs and a physical mounting spot for the GPS to get a clear view of the sky. Thankfully Sparkfun, Adafruit etc have pretty good Arduino libraries and I’ve been able to test a few chips over the last couple years to confirm its doable.

Interesting but quite expensive chip. I hoped that APD had this ability, but guess its more complicated than that.

Successfully updated throttle to 5.8r and APD_HVPUHV_Mar2023_Rev1 firmware.
I notice now that motor start is much more smoother, not that coggy anymore.

In motor options you also have tese:

Timing Advance
Increased timing advance can reduce ESC running temperatures with some motors. The recommended setting is auto.

PWM Drive Frequency
Forces the output frequency to the motor. Recommended is auto setting enabled where possible.

I swapped to auto but the current draw was 0,1A more(at full thr “chill” without prop) and the sound seemed louder so switched back.
What is you recomendation there?

Also, how ome my controller does not vibrate? (never did since I bought it)
I have the one with the newer chip.

Yep the newest controllers dont support vibration.
We’ve heard feedback that this is handy so we’re looking to bring it back in the next design.

@zjwhitehead, Is it recommended to update the ESC to 2.1.2 (APD_HVPUHV_Mar2023_Rev1) if we update to Controller 6.0? If so, are there specific setting we will need to change or will the default install work as expected?

Yes, I’d recommend it, as both new firmware offer more stability. However if you’re not comfortable upgrading and dont have any issues its certainly not required.

1 Like

@zjwhitehead Great. Will do. Can you answer this bit as well re: the ESC update: “If so, are there specific setting we will need to change or will the default install work as expected?”

1 Like

@zjwhitehead Well… I think I bricked my ESC and I’m feeling sick to my stomach.

I followed the instructions (Firmware Installation - Advanced Power Drives), installed STM DFUSE and the Configurator, and the Configurator then threw the error “ESC Unsupported”, so I then followed the instructions in the “Older Firmware Upgrades” section and opened DFUSE. Nothing showed up, so I updated the drivers as instructed. The ESC then showed up and I chose the latest firmware file and clicked “Upgrade”. It then sat at 0% on downloading for about 5 minutes, then crashed out.

Now, I can’t get the ESC to show up anywhere. Not in Device Manager, Configurator, or DFUSE. I’ve rebooted, and reinstalled all the software and drivers. Still nothing.

I don’t know what to do. Any and all help appreciated. No beeps and controller shows battery error when I plug in the battery.

Hey there, it sounds like you tried a couple different things so I’m sending you a DM for next steps to send it to get looked at.

Just as a general forum update, I was able to get the ESC back into DFU mode by disconnecting the motor cables, connecting Phase C to Negative, and shorting the boot pins on the edge of the board while plugging in the ESC as suggested by APD. Turns out it was the Surface laptop I was using causing the issues and freezing DFUSE. Once I tried with an HP Intel laptop, all was well! Huzzah.

The startup is WAAAAY less “coggy” now. Can’t wait to throw a prop on and fly it.

I did have a controller reboot while testing changing from Chill to Sport… hope that’s not a common thing.

I noticed the same issue when changing from chill to sport mode, controller rebooted (6.0 version). I switched back to 5.8 because I didn’t like the new arming sequence, I prefer just double click.

Yup start up is much more smooth, but spin down can sound weird if you drop the the throttle quick. You will also notice much less power at low battery so to compensate I sometimes switch to sport mode at low voltage.