Motors go into disarm mode but says armed on remote

I was out flying this evening and with two launch attempts the motors went into disarm mode as I was about to start my run. The throttle still said the motors were armed but throttle was not responsive and were making the beeping sound as if they were disarmed. Cycling the power got it to work again. But it did this twice. I would test the motors before getting ready to launch, then it would disarm on its own about a minute after arming. Third time it worked and was able to fly. Anyone else ever see this? Thoughts? I have x4 v3.2 not sure what version my controller is deemed.

I have a batch 3, and last May my throttle cable developed an intermittent short as I was trying to launch…not good! I ended up building a new throttle cable that solved all of my problems. I think your throttle board may have solder tabs…which will be easier than what I had to deal with. Bill

1 Like

I had this happen a few times last year. I have a v3.2 (but now has a v6 board in it). It turned out to be a loose throttle cable connection right at the hub, the actual cable/connector point.

I ended up using a screwdriver to re-seat the cable in the connector (seating each pin individually) and secure the cable with sufficient slack that there is no tension on the connector during flying/folding. That stopped the problem.

Seems like if the throttle controller looses communication with the hub, you end up in this situation where the throttle is still armed but the hub is not.

Thanks guys will investigate the throttle cable! Does the new v6 board have a better way of connecting the throttle cable? Should I upgrade the board?

No, it is the same connector. The 6 has 6 wires vs. the 4 for v3.2. Upgrading will require a new hub, cable & throttle controller.

I only upgraded because I had a dead short between an ESC power lead and the control circuit, on the hub. Burned so many things…

Although I do like the altitude feature…

1 Like

I experienced the same issue with my batch 4. Happened at least once on the ground before I launched and once in the air while I was, fortunately, gliding to land. Power cycle cleared the issue both times.

Then one day I was ready to launch and my voltage regulator quit regulating. The hub and controller board fried and have now been replaced with V6 components. No way to tell if these issues were related. The V6 voltage regulator is larger (more robust) and the V6 hub has over voltage protection.

I like the altimeter too!

Scary it happened during landing. Do you remember if you were off the throttle when it happened? For me it’s always when I’m off the throttle it’ll go into this mode randomly. I have emailed in to see if I can get new board/throttle.

Mine would randomly disarm because of the throttle cable problem. The scary part was that some or none of the motors would work when I re-armed. The result from the first time that it happened was that on launch the two “port” motors came on…the two right did not. The result was a serious torque steer to the right before I left the ground. I took a knee, trashed the two bottom hoop connectors and the three bottom hoop segments. The good things that came out of it were 1) I wasn’t hurt, 2) I designed a really robust hoop connector retrofit and 3) a heavy duty throttle cable. I have more confidence in my X4 now…electric is new, but it is the future…we’ve just got new/ different problems to overcome than we had/have with our ICE units. By far…our electrics will ultimately be more reliable. Bill

Yes. I was off the “throttle”. I was just practicing my approaches and was gliding in, lined up perfect and noticed the motors beeping. Checked power. No response. Cycled arming. No response. Landed. Cycle power. Everything good so I launched again and did a few more approaches.
I was cautious after that to never back completely off the power. My V6 electronics have been rock solid.

1 Like

Any suggestions how to get ahold of @zjwhitehead for ordering new controller? I’ve sent two emails in the past 2 weeks with no response.

Sorry for the delay, we realized we had an issue with the contact form on the website. Looking at your email now.

1 Like

What type of wire did you use? I’m wondering if the current cable is picking up interference since I don’t think it is shielded.

24ga stranded silicone wire and metal cloth shielding tape. Both came from Amazon…the wire was made in China…not sure about the tape. Follow my link above to take you to the cable build photos. I always do an arm/run up moving my arm around before launch as an extra check. So far, it has been solid.:+1:

Thanks great details on the cable rebuild. I’m thinking of using aircraft grade wire, it’s stiff but very well shielded.

1 Like

All done. Anyone know what the tiny connector is on the remote end? Would prefer not to splice wires just another weak point. Had some of the aircraft wire on hand. Will try it out and post results if system goes into disable mode still


Nice job! Yep, solder pads would have been a better design…more robust. I never had any problems with them on my quadcopter builds. Those connectors are ultra small, and I am not comfortable trying to crimp ends and build them. My crimping tool only goes down to .1" spacing or .025" square pins…like on the arduino…and those are pretty small. The throttle ends are tiny! For me it would just be something else to go wrong.

True they are super tiny, it’s a shame not same 2.5mm JST as the other end, we must have same crimper.

Sadly running it in the office the unit still randomly goes into disarm without putting it in disarm mode, only recycle of power gets it back. Only happens when you give it throttle then going to idle, never when inputting throttle.

Yup. I was in the habit of holding a very light but of power, like an idling i.c.e. Then the dc-dc converter quit and burned chips. V6 hub and controller are solid.