Help with controller connection

Just wired up my batch 4 and my motors are not spinning!
Any suggestions appreciated.
(Initially, there was no power to the hub: I had to rotate the tiny preset screw many times until the voltage was high enough). It looks like everything is powered up but the controller is not talking to the ESCs.

I am able to arm & disarm, but nothing happens when I depress the thumb throttle. The motor is beeping. I am connecting each motor separately to test. The green light on the hub is blinking off and on regularly every 0.5 second. I can change pages on the controller: everything is reading zero. I connect the 2 wider leads To the hub: 1st is the black+white, then the other, both with the white lead at the top. Any other connections required??
I was thinking of doing a continuity test on the controller connecting lead since it is very firmly squashed where it enters the casing (to act as a cable clamp). Any insight appreciated.

Just a bit of fishing here but maybe check the voltage on the output side of the the DC-DC power supply again. And yeah, checking for a broken controller lead seems prudent too.

Thanks for that. I will try both those things. Do the motors normally beep?? Or is that them saying they have no communication link? When I test the DC-DC output it never gets to 5v however much I turn the pot. I wonder if I need to disconnect the DC-DC before measuring?

The hub will probably work at less than 5V but I wouldn’t know how much less. My old RC plane recievers and motor controllers were happy down to 4.4 or less. What does your converter reach?
Yes the motors should all beep when powered up. They stop when you arm the controller. If they’re beeping that means the controller isn’t armed. Clear props then double tap the top button.

Thanks Greg. I’ve got the controller to 5v now but still motors not spinning. The controller is arming ok but motors still beeping. Throttle not working, everything zero on display. Next I will do the continuity test on the wires. I’ve contacted Paul/Zach but no answer yet. Will keep you updated.

Done the continuity: its fine so that’s not the issue. What’s the best way of contacting Paul or Zach? I’ve sent an email to info@openppg.com.

Might want to double check what the voltage is supposed to be for your throttle version because many PCBs run on 3.3v

Sounds like the controller is functioning but the signal isn’t getting to the hub. Does the controller say armed when you arm it?

Apparently… wait.

Hi. Yes, it says armed. I will try 3.3v but I gradually increased it anyway. everything reads zero on the throttle display.

I wasn’t suggesting the voltage was your issue and to just try 3.3V. I was saying you need to know what the voltage of the board is supposed to be and use that voltage. Using the wrong voltage might work at first but could cause problems down the road.

Sounds like the controller is working. You might have a loose connection or broken wire between the controller and the hub. Is there a LED on the hub? Send pictures and video of the issue.

Hey @Andyoptom
A couple things to check:

  • Ensure the ESCs are connected properly. It can be a little confusing but sounds like you have it right
  • Ensure the cable isnt pinched and all the wires have continuity. Sounds like power and ground are working ok but the slow blinking LED indicates the hub isnt getting any data from the controller.
    If your cable is damaged we can send you a new one.

IMG_7361 IMG_7360

Every other connection is for PWM and Telemetry (TELE). So the PWM wires (black and white) go where I marked in blue.

image

For telemetry (marked in green) plug in the the white, red, and black. The white goes on top and the black goes on the bottom for both. The last two wires on each ribbon are not used (yellow and white).

Hard to tell from your picture but do you have only two ESCs connected or do you have 4 PWM wires in the wrong place?

Also, I don’t see that you have your controller plugged in at all.

I hope this helps.

Thanks Paul.

Yes I only have 2 ESCs connected & the controller happened not to be connected when I took the photos, but usually is. I am posting another photo. I THINK I am connecting the wires correctly: I’ve tried starting at the other end & I’ve tried swapping them over also. No luck. I assume PWM are the 1st wires in the ribbon: black, red, white. Telemetry the next: just black & white. Any ideas??? I have 2 videos which I will try to post but its not allowing the MOV format.IMG_7392

you can see the videos at the following web address…

Anyone can view this shared album at: https://www.icloud.com/sharedalbum/#B0ZGY8gBYq7qTk

Hey Andy,

You have the orientation correct (white wire on top)… However, you have your PWM and telemetry swapped. As shown in @GliderPilot’s photo above, as well as in the instructional vids by Paul, starting from the memory card port, the two-wire (black and white) should be first, then the three-wire, repeating…

Once you have the wires the correct way around, you’ll find that the ESC’s will stop beeping whilst the controller is armed.

I hope that’s enough to get you going.

Thanks Nick. I tried that and still the same problem unfortunately. It looks like I now at least have the wires plugged in correctly? I’ve left another video at the same web address: https://www.icloud.com/sharedalbum/#B0ZGY8gBYq7qTk

I tried another motor: just the same. Any ideas?

Hard to say, but it‘s likely either the hub or the ESC that’s the problem… have you tried plugging all four in, just to see if the beeping stops when you arm?

Next, try a different ESC on the hub, and see if the behaviour is any different. If not, that would suggest it’s the hub causing the issue, and not that particular ESC. I’m assuming you are powering the ESC correctly!?

Sadly, I can’t suggest anything further at this time. In the next day or two, I’ll see if I can test exactly the same setup, to see if it works with only a single ESC plugged in.

It’s not the ESCs or the motors because they are redundant and wouldn’t all stop at the same time… and they are beeping. I don’t think it’s the controller because it responds and shows armed when you arm it. It’s got to be the hub or the cable connecting the controller to the hub. The wires in that cable are really small and break really easy… check for broken wires at both ends of that cable.

Thanks. I’ve thoroughly inspected the controller-to-hub wire: I’ve posted an example continuity test video to the same iCloud web address: https://www.icloud.com/sharedalbum/#B0ZGY8gBYq7qTk.
I’ve check all 6 wires and they are all fine for continuity and no conduct with adjacent wires. I’ve also thoroughly inspected both pcbs & there’s no sign of solder bridges or anything loose or burnt out.