Can't reboot in update mode

Hi all.

I’m trying to update the firmware on my throttle controller. When it’s in “normal” mode, I can connect fine. Plug in the USB, connect with my browser, and everything seems to be communicating correctly.

When I click on the yellow “Reboot in update mode” button, the screen on the throttle controller flashes a brief message – “BL - UF2” and then goes blank. My understanding is that it’s supposed to be booting into a mode where it shows up as a flash drive on my computer, and the next step would be to drop the firmware onto this “flash drive.”

But after the screen goes black, it doesn’t reconnect as a flash drive on my computer. It doesn’t appear to have any power at all, the screen stays dark. My computer can’t see it at all. (FWIW, it’s a Macbook Air M2) I can’t do anything except unplug the throttle controller, and plug it back in, and it comes back in “normal mode.” I can’t get it to show up as an external drive.

Any ideas?

Thank you!


1 Like

I just updated my son’s throttle controller, and everything worked as expected, no problem at all.

But my controller (installed firmware version is 5.6) just refuses to reboot in update mode.

How do I fix it?

@zjwhitehead @Pdwhite

Thank you!

1 Like

Do you have a windows PC or an Android device to try this on? Perhaps the mac is for some reason not recognizing this device’s drive.

I have this same exact issue. I’ve successfully updated in the past with a Windows computer and currently run 5.6. Now I can’t get any of 3 computers (2 Mac, 1 Windows) to recognize it as a USB device. I can get into the configurator and it’s recognized there but they’re only. In the past my computer automatically recognized it as a USB drive but now it no longer sees it, even when I reboot in update mode. Sorry I can’t help, just here to vent about the same problem I’ve had since 5.7 first released and I wanted to update…

I’m going to try a different computer, but I don’t think it’s going to work. Have you contacted the OpenPPG guys about the problem?

Only on this forum.

Figured it wasn’t a huge deal as everything works fine in 5.6, but it would be nice to be able to access updates in the future.

Mine won’t boot with the UF2 bootloader. I’ve tried multiple computers and multiple cables. My son’s throttle controller behaves as expected, so there’s something wrong with mine. I’m going to contact OpenPPG and ask how to re-load the firmware and bootloader.