Bootloader drive doesnt show up on computer

Well for probably the most tech-illiterate question on this forum: how do I force my computer to see the controller as a USB device in file explorer? I’ve successfully updated firmware in the past and when I plugged in the controller into my computer that time, it popped up as a device automatically. This time, I’m able to connect via the configurator (shows connected in Chrome) and it shows as a USB device in Device Manager on Windows, but does not appear in File Explorer. I don’t really want to risk bricking my $7500 machine by willy-nilly updating USB drivers, so figured I’d ask here first.

Tried connecting with several USB cables (including one I’ve successfully updated with in the past) and on a Windows 10 and a Mac computer.

You’ll need to hit the connect button and then at the bottom reboot into bootloader mode.
That will make it show up as a drive

I’m able to connect to the configurator; when I hit “Reboot into bootloader mode” the controller screen shows “BL - UF2” then goes dark, then the configurator shows the controller as disconnected and the Arduino still does not show up as a drive, even giving it a few minutes. The only way to reconnect is to unplug and plug the controller back in, but still it will not show up as a drive. Again, on two different computers and multiple USB cables.

@skduncan560, have you been able to fix your problem yet?

No. Fortunately, the controller works fine with 5.6 as-is, just can’t update due to this problem.

We’re you ever able to get it to show up as a drive on your computer? I still can’t get mine to show up period. Different cables, the same cable I updated with before, nothing.

Yes. The previous time I updated the controller, as soon as I plugged it into my computer I got a pop-up showing it as a new drive connected to the computer and was able to find it in File Explorer as a drive. Basically, exactly what the video tutorial shows on the site. Not sure why it’s not doing the same this time…

As an update, I figured I’d open up the controller and double tap the reset button, as this seemed to be something to try as a possible fix to other controller problems in these forums. The controller reset, I plugged it back in, still didn’t show up. As before, the configurator sees the controller and is able to make changes (e.g. sport-chill, meters-feet), but the computer just can’t find it as a drive. I tried with the controller plugged in and not plugged into the ESC: no luck either way. Finally went through a tutorial on how to find connected USB devices on a Mac but still nothing. Weirdly, the Adafruit Feather shows up as a USB device in System Information, but does not show as a drive in Finder. Same thing on a Windows machine.

TL;DR: tried some more stuff, still no luck.

I’m in the same position. I’m hoping they’ll post a tutorial on how to use the debugger from Mousers. I’d like to be able to fix this without having to send back. Especially if it happens everytime I update firmware. I bought a new throttle as well and only getting a battery error on it, no response from motor.