Trouble Arming the Motors

I have just replaced the HUB, DC/DC Buck Converter and, the Throttle. When I powered up, the motors beeped and twitched. Upon double click, the throttle vibrated and showed to be armed. But, the motors continued to beep and, they did not respond to pressing the throttle plunger.

Does anyone have any ideas to correct this?

Thank you for any help

First thing I’d check is that the motor controllers are plugged into the Hub properly. Seems like they have power but not signal.

I was careful while installing the new HUB (unplugging from the old HUB each wire one at a time). But, I am on my way to double-check that now.

You are right about them having power though. When I get close to them, I hear each motor beeping. It seems they are just not communicating with the throttle.

Thanks for the input.

How close? I can hear mine beeping when disarmed from at least a few meters away.

Check the cable from the throttle where it connects to the hub. If you have to, take a small screwdriver or pin and seat each of the wire pins between the cable and the hub.

I had the same issue and it turned out to be that connector.

by the way:
the motors shouldn’t be beeping.

it’s the ESC’s that are beeping when they have power, but are not “armed”

so from what you describe, if it’s really the ESCs that are beeping, your ESCs are not armed, the instruction from the throttle does not go through to the ESCs.

Also, very important, do not tell any 2 stroke paramotor pilots of these troubles! I’ve been smugly posting on the FB groups how wonderful and reliable my electric paramotor is whenever I read posts about engine outs.

:wink::wink:

1 Like

Hi. I had this exact same problem. Paul/Zach eventually replaced my hub & throttle cable & this did not fix it. Then they sent a REPLACEMENT THROTTLE BOARD & it works fine now.

Hi!
I had this once… and somehow, I found out that it was because I had an SDcard inserted in the hub. Without sd-card it worked again… it’s worth a try.
And btw, I still am not able to have the logs recorded to an sdcard up to this day. (I tried a few different cards…even bought a new one for that purpose…from 4 to 128gb)

Thank You all for the attempts to help. I have tried every suggestion except the “Throttle Board”. This is the first I am hearing about that. There is no SD Card inserted, the pins at the connection have been snugged. The cable and HUB are new. And still the same situation. I am my pulling my hair out at this point!

Thank you all again for the help. If anyone thinks of something else, please post.

Hopeful, MAO

Ya if your motors are beeping it just means there is no pwm going to them. Or the signal range could be out side what the ESC is looking for. So like most ESC operate on a pwm signal that should be between the ranges of 1000 to 2000 (1-2ms) So if you have a signal generator that say is generating a signal of 985 the ESC will beep like it has no signal, that might be what’s happening in this case. So that’s why all esc will have a throttle calibrate setting and the esc will recalibrate the min and max ranges to match the min and max to the incoming signal of the pwm generator (this case the hub).

Also the ESC looks at the signal when its turned on so if its out side the range when its turned on it will beep.

So what i would do first would be just to make sure its outputting a pwm signal at all. You dont need a oscilloscope or anything, you can just take a cheap multimeter and put the probes on the signal and ground line If there is no pwm signal i there would be like 1v or no voltage. If there is a signal it might be around 1.5v but if you go from min throttle to max you should see the voltage raise maybe from 1.5v to 2v. So with more throttle the voltage should go up. Im out of town so i can give you exact numbers but it should be close.

Thank You for the input. I have my multimeter at the ready.

When you post the exact numbers could you add a photo so I’m sure that I’m on the correct points. And, also, please explain how to adjust the calibration, should I find the voltage outside the range.

Thanks again

Here’s the video,

That should help orient you.

2 Likes