SP140 Battery Error

Have any of you guys seen this issue yet? After an awesome flight last weekend I flew right at an hour it died over the LZ and landed fine. I disconnected the battery and re connected it to see if it would say how long my flight time was and saw this but figured it was dead. Charged it this week and got theses results: Battery 100%- Connect power - controller boots up- no beep from esc on start up- no beeps saying it’s connected- but will arm and disarm however it won’t do anything.

Went over a few checks per @glydrfreak

-Blue light is on inside throttle.
-I checked all Plugs twice.
-Checked voltage between black and yellow. 4.96
-Checked voltage between yellow and white 10.27
-Checked voltage between yellow and red and it changes when I squeeze the throttle.
-Checked voltage between orange and black 3.12.

Seems as if the esc is sending an incorrect readout or telemetry back to the controller.

On two previous flights it randomly disarmed at cruise power.
1.30TT on unit.

Any ideas?

Also, I Manually Checked battery voltage on the battery at the connector. 99.1v


Back working by simply re-loading the firmware. Not really sure what happened or why it did that.


Hmm, I’m doubtfull that reloading the firmware actually fixed the issue. Sounds more like you have a loose pin or loose connection at the ESC. Mine did that after I extended my cable for right hand throttle operation until I improve the connection by soldering directly to the pins on the ESC.

I checked all connections thoroughly. Like 4 times… lol whatever it was it seems to be okay for the time being.

So you don’t use a connector anymore at the esc, your throttle wires are soldered directly to esc pins?

Yes, I soldered the pins directly to the ESC, but i have a short, 3" harness section with an 8 pin screw threaded connector. So i can still remove or replace the throttle cable, but there is now a firm screw thread holding the connector locked.

1 Like

That sounds good. I might do something similar, but go with an automotive type waterproof connector. I have all the crimping tools for those type connector pins. And they work great on cars bouncing down the road.

Well, updated the firmware on my new throttle. Still getting battery error, no response from esc, motor.

Today checked to see what my ESC firmware version was. Thought I could see just by looking at the usb Drive when it connected on my laptop. Unfortunately it didn’t show, I had no internet connection in my shop and hadn’t downloaded the ESC configuration yet. Disconnected from ESC. Decided to connect the battery again, and out of nowhere hear the arming beeps on throttle controller. Armed throttle and gave it a squeeze. Motor moved a little, but didn’t turn. I spun it by hand and gave some throttle and she kicked in. Runs in all modes, cruise works. Drained the full battery by running on cruise with no prop. Ran for an hour and lowered it 3 volts I think. Tried other battery and works as well. Yay. I guess hooking up ESC to usb on laptop was enough to wake up my ESC

Just to inform you I had a similar problem (and thanks to this feed, could also solve it).

After flying a while very fine with a 2.2KWh battery, I ordered a 4KWh one, tested it at home (started up motor), and went out for trying it out in the air.
But… when connecting the battery in the field, I got : ‘battery error’ on my throttle.
Changed to the 2.2KWh battery : same.

At home , checked batteries (I always get some errors on the smart BMS app, but voltage comes out fine), connections, …
The upgraded the throttle software (from 5.5 to 5.7) : same
On the ESC, 100V on the battery cables, so I assume it should be in the digital protocol between ESC and throttle.
Then I downloaded the APD configurator in the hope to get some clues.
I connect my PC to the APD, but did not proceed when it asked to solve the incompatibility (see video of Paul for more info how to proceed).
Instead, having in mind your ‘solution’, I reconnected the throttle and battery and… system started up correctly !!
Ofcourse, now I will try to get again in the air.

Thanks for the hint ! Not sure what exactly happens, but it solved the problem.

Glad it worked for you too. Hopefully get some more flying on mine this week.

Hey Ryno, Eagleuh1,

Did you make any progress on the battery error topic ?

Today, looked again at my setup. The battery error is still present.
But connecting a battery pack to the APD module usb port, also solves the problem.
If I then just arm the setup, disarm it, and disconnect the battery, then it will start up fine the next time.
However, if after arming, I just run the propeller for a few centimeter (or inches), then disarm, disconnect the battery, the next time, it will show again the ‘battery error’. Quite consistent.
So I assume it is a power down/power up issue in the APD module with throttle connected (a floating node, …).
But I have no idea why the problem only popped up after a few months…

See if you can update throttle to 5.8r and esc with APD_HVPUHV_Mar2023_Rev1 firmware. those are the latest for now.
I had the same issue(battery not recognized) with mine once and APD gave me recommendation on disable logging from the configurator tool. This helped with the battery issue for me.