One ESC Stopped on X4

Hello world,

My left lower motor sopped mid flight.
I have the batch 4 -14S - 4 sets of battery’s, of the X4 with the X-Rotor pro HV 80A and the extra external capacitors.

After repower the whole system and test everything on the ground I could not reproduce the issue. When relaunching once more, the motor stopped almost immediately after takeoff. When landed and rebooted once more, doing some ground test, no issue at all.

If someone have some experience with reading out the data from the ESC, please informs how to do this as I’m interested in the error message of the ESC.

I cant find any manual of the ESC but the website claims it should be possible to read out the ESC.

Thanks in advance!


Do you have a microsd card handy that you can insert into the hub?
There should be CSV logs on it once you reboot it and try again

I have a micro SD card in the hub from flight one but when I insert it in the computer there is no data on it. Any idea what can be the reason the SD card have no logs on it?

If I think about it the SD card slot on my hub probably never worked. When I wanted to update the software on the hub I had to do it with the NUCLEO programmer because the .bin file was never detected on multiple types of SD cards that I put in the SD card Slot on the hub.

Make sure it’s fat32 format and not larger than 32gb

The SdCart Works now.
I have logs on it but no data in the logs.
Someone had the same issue?

Can you send a pic of how the ESC signal and telemetry wires are connected to the hub?
Are you getting voltage data on the screen?

How did the story with the ESC end? A friend of mine has exactly the same ESC behaviour; halfway take-off one motor always stops. After landing and rebooting the motor runs again, but will stop again half-way take-off. I exchanged the ESC against one of my ESCs, and he has no issues anymore. So it is the ESC. He cannot do any logging, since he got a batch 2 set, which has no hub with SD card.

The ESC issue did not reproduce itself till now. It was only that single day where it happend two times. When it happens once more I will post it.

Double check the solder joints of the added capacitors. Inspect the motor for blackened wires in the coils. I had a short in one motor that cause me the same problems. I fixed the motor and haven’t had problems since.