No Charge- BMS and Charging Troubleshooting


Newbie here. Need some help with charging and BMS.

I can use my system but not charge the battery.

Only 1 cycle on the battery. Think my BMS is bad? Charger seems to be working and has voltage. Second flight had an hard cut and now I can’t charge. Could that kill the BMS? Appreciate any help.


I’m new to the SP140 and far from an expert, so take my advice for what it is:

  1. The battery voltages are averaging about 3.65v with 24 cells. This should equal a total voltage of 87.6 V, which is a lower state of charge. It seems even lower than the 45% displayed in the app, but I’m just guessing.
  2. Your charger is showing 100.6V at zero amps. This would be displayed if your charger isn’t hooked up to the battery properly.
    Check the following;
  3. Make sure to connect your charger to the battery first. Don’t connect it to the controller, connect it to the battery. I have a feeling you’ve connected the charger to the controller side.
  4. Plug the charger to wall outlet.
  5. Report back findings.

Thank you so much for the help. I have checked. I am plugged into the battery not the ems but good thought. I have charged it once before after it arrived and it worked fine. Charged to 100%. I then ran it and it stopped in flight around 90% I realized the charger was not working and ran it down to 87 because I heard that’s best place to keep it why I figure this out. Updated the Controller and EMC to latest version.

Weird thing is:
Battery works to power motor - this means battery is good and connection is good.
Charger works to power other things. This means charger is good. Connection is good.

So… why don’t they like each other? I am sure I am missing something easy…

Ok, that was great to check that it’s plugged in corrected. The voltage and amperage displayed on the charger indicate an open circuit. You can verify this by plugging in the charger when it’s not connected to anything at all.
So next check that all the wires are connected solidly on the charger going into the connector. They are somewhat small wires, so they may be disconnected on one side or the other. There isn’t an easy way to OHM them out, so a visual inspection will work. If you can’t see anything wrong there, I would suspect a BMS issue, which I can’t help with.
I would also try running the battery down a little more, and connecting/reconnecting it several times.
Similar to re-booting a computer when you have an issue with it.

So charger plugged into nothing gives me this. Does that indicate a charger short somewhere?
Should I open up the charger

The charger plugged into nothing is reading the same voltage (100.6V) and amerage (0A) as when it’s plugged into your battery. So this means the charger isn’t connected (an open wire somewhere; not a short) to the battery, or it’s connected to the battery but the BMS won’t allow it to connect to the battery.
You can call me at 208-695-4546 if you’d like. I’m not on the forums/email often enouth to respond in a timely mannner.

First off thanks Agile Mike for the phone troubleshooting today. Narrowed it down to most likely a BMS issue.


  1. Anyone know how to confirm/return a bad BMS? (Daly Bluetooth version)

  2. Anyone know how to test a charger just in case it’s the culprit?

Thank you everyone for the help. Great community!

You and @Vanningaintnojoke are having the exact same issue. I do not suspect it is your charger.
I used my charger to try to charge his battery and it did not charge yet it worked on my batterys without issue

Yes it seems odd. Paul had me order another charger anyway. I will report when that arrives what happens. Hopefully that’s all it is.

This topic was automatically closed after 13 hours. New replies are no longer allowed.