How do I charge the SP140 battery?

Just received my SP140 and put it together… super excited! :smile:

I feel a bit silly/ignorant, though… I can’t seem to charge the battery. I plugged it into the charger and let it sit overnight. I then connected the battery to the motor. The first few times I tried, the controller would beep and turn on for a fraction of a second, then immediately turn off. Video for reference:

Now it doesn’t even do that; I don’t get a beep or controller flash.

The red and green leds on charger are always on.

I downloaded the BMS app but I have no clue how to use it. I was able at one point to get the battery to show up and saw this:

Now, I can’t seem to get the battery to show up in the app again.

Would appreciate any ideas or recommendations. I can’t wait to fly this thing!

Note: I know nothing about battery technology :see_no_evil:

Are you charging in a cold garage or something? Could your battery really be at -40 degrees? Looks like the BMS thinks it’s too cold and therefore won’t charge or discharge and thus the screen turns off immediately because the BMS is turning the battery off. I doubt its really that cold so you may have a faulty BMS or a bad temperature sensor.

You could experiment with the low temperature setting and set it really low to override the low temp fault just to see if that will make it charge.

Looks like the low limit for temperature on mine is set at zero. I changed mine to see how low it would let me set it and it won’t let me set it below -40. You could try -40 just to see what happens since it probably isn’t actually that cold but I don’t think that will be low enough to trick it.

When you type a value and press set the password is 123456.

Hmm… it shouldn’t be anywhere near -40. Been charging in my living room at around 70 F haha. Maybe it got that cold if it was shipped via air? but I assume it would have been regular freight. Broken temperature sensor sounds most plausible.

I’m still having trouble getting it to show up in the BMS app again but I’ll keep fiddling with it throughout the day and report back.

Thanks again for the help!

It has to be actually charging or attached to ESC, motor to activate the Bluetooth and BMS, to be able to see it on the App.

Tried connecting to charger and motor both with power on and off. Still no luck :grimacing:. Maybe the battery is completely depleted (hence the controller not flashing on and off anymore)? and of course it’s not accepting a charge. I think I’m going to see if I can send it in for an exchange now that it appears to be a hardware thing (vs a me being clueless thing haha). Thangs guys

Put a voltmeter on it to see what charge is. BMS will shut it off before full discharge. When you open the app, does it even see the battery? It should show a serial number, then tap on that and it will open. You have to connect it up for it yo turn on Bluetooth also. Does your battery have the switch on top? Mine don’t. Might be obvious, but I’ll say it anyways, turn the switch on after connecting.

I’ll see if I can borrow or pick up a voltmeter this afternoon. I am able to get it to show up for about a minute now in the app by turning off, unplugging, then replugging in, and turning on. It only shows for about a minute before disconnecting and disappearing from the app. This is the latest screenshot:

I was able to update the min charge temp and min discharge temp to -40 before taking that screenshot.

Your battery is not depleted because the cells are at 3.5ish volts and that’s not low enough to trip the low voltage limit. The battery shuts down when certain limits are exceeded. In your case the low temperature limit is what is exceeded. I agree you need to send it back to be repaired or replaced.

1 Like

If the BMS is shutting the battery down for any reason then the voltage meter will probably just read zero. Regardless, you don’t need to check the voltage cause the BMS is showing a good voltage.

It shows only 10 strings here. You should have 24 so Try change that in settings.

That’s weird, his first picture shows 24. I don’t think that’s a setting you can change in the app.

Just got an email back from Paul; going to send it in to see if they can figure out what’s going on or get it replaced. I’ll follow up here if there are any learnings. Thanks everyone!


The BMS bluetooth only stays on for about a minute after you stop charge or disconnect from ESC. Unless you change that setting in the app.

1 Like

Opened it up… the temperature sensor was smashed :pensive:. Working with Paul to figure out how to get it replaced

1 Like

Any idea how? This app is so unintuitive for the layman haha

I don’t think the number of strings is a setting. The BMS probably detects how many are connected. I don’t remember seeing it in the settings but I could be wrong… just scroll through all menus and see.

If you set to 1 it enables it and set to zero to disable it.

Just got a new battery in the mail :smile: .

I have a couple more questions, though :see_no_evil: .

Is it normal for the charger fan to cycle on and off like every 6 seconds? Kinda weird it spins hard then not at all… would expect it to continually spin low (like a pc fan).

The app shows it being 99.2% charged, but the throttle says it’s only 69% charged. Shouldn’t these match?

The fan being like that is normal. Just charge it upp fully to 100V and the app will readjust. Dont look at the procentage, rather on the voltage. The controller is showing a more correct value for you.