Help with arming

Just got my new hub installed. However the controller will not arm, screen is dead.

I know one of the esc’s telemetry is damaged, but should that stop the controller screen from lighting?


All the esc’s are fixed and operational.
Checked the cable, connectivity is good.
Opened up the controller and when I press the reset button the blue LED button lights. Screen remains off.
Checked the buck, 5.11 volts to the hub.
Tried to power up the controller through the micro usb. Red power led lights, but the screen remains off.

I can run all the esc’s and motors with a RC receiver, but not with the hub.

See if you can connect with the controller trough
Only chrome internet browser will work!

If so you can upload the final firmware to the controller.

Hope it helps!

The controller will not connect, “no compatible device found”.

The red power led in the controller does connect, but no other outputs.

This is a brand new controller and hub that I bought from Paul, should it really need a firmware update right away?

other option is:

if that is not working you need to compile and upload the Arduino code yourself as described in this github page:

one remark: on the libraries:
AceButton use V1.4.3 , Otherwise error file AdjustableButtonConfig.h not found

if one of those options worked you can use the config chrome site from then on.

My problem is that there is no communications with the controller. It seems to be using power only from the micro USB.

Also try disconnecting the screen. I’ve seen them rarely cause a failure to boot fully.

With the screen unplugged it boots up, arms, and runs. Thanks!

When I plug in the screen, it goes back to troublesome ways.

I can fly without the screen, but do you have ideas for getting the screen back?

Ummm… I don’t think that is supposed to be loose…

It looks like that connector ripped off the solder pad :slightly_frowning_face:
The screens are cheap to replace but that board will be a bit more.

You can certainly fly without the screen for now but you’ll be missing key information especially the battery voltage (which you dont want to draw too low).

How are you with soldering? Also could you send a picture of the screen with the wires attached?

I’m ok with soldering. But it looks like one of the pads is not connected to the board (second from right above). I don’t know if that circuit will function…

I can fly with a screamer connected to one of the batteries’ balance connectors, but that only gives me an end point. A screen would be nice.

I’m going to attempt to solder the connector back on, just happy that it is running right now.

I do have a screen from the old 3.5 controller, don’t think it was affected by the short. Are they the same?

Soldered the connector. Plugged in my screen from batch 3.5 because it looks to be the same. X4 arms and runs, but screen is still dead.

If you want, you can send it to me and I can probably do some micro surgery by jumping a wire from the lifted pad to a via on the same trace that the lifted pad was on. Actually you seem capable of doing it yourself, especially after soldering that connector back on. I kinda doubt your screen is damaged but if it is I can test the connector with another screen I have.

I’ve seen rare issues of similar screens preventing boot up on other projects I’ve done. Super strange.

1 Like

Thanks for the offer.

That is exactly what I did. :slight_smile: Jumpered the pad to a nearby hole on the same circuit. The screen that came with the controller is still dead, but I used the screen from my 3.5 controller which seems to work just fine. Unit is now operational, screen works, boots, etc.

My only problem right now is that the controller won’t connect to openppg-config program so the display is upside down (it’s in right hand mode right now).