First time battery plug in doesn't always work

When I plug the battery into the ESC, about half the time it doesn’t boot up properly. I get kind of a single, weak beep, and the throttle controller doesn’t boot. The screen is blank. If I unplug the battery and re-connect, it usually boots up correctly. Any idea why it’s not booting up correctly the first time?

The BMS is thinking there is a short so as a safety measure it’s shutting off. Unplugging and plugging back in will fix it but it is also on the list of improvements to make. I think it can be solved with a BMS setting getting tweaked.

Makes sense. Thank you!

The ESC has big capacitors in it, so a large current flows for a very short time when you first connect the battery to it. I read that the connector has a pre-charge resistor (like on R/C connectors) where it will gently charge the capacitors if you connect it half way first?

I downloaded the BMS app called SMART BMS. And increased the max discharge amps from 230 to 280 and this fixed the issue.


Mine did the same thing when I first got it. But after awhile it stopped doing it.

Has anyone found any decent BMS apps for iPhone/iOS? I see a few on the app store, but if anyone has already tried them all, I’m open to recommendations. :slight_smile:

I use the one Paul talked about in his YouTube video. The SmartBMS one.

It looks like Paul is using an Android phone in the video? Am I not seeing that correctly?

Yes, an Android phone is shown off in the video.
I dont have an iPhone to test but it looks like this is the same app for iOS

1 Like

Yes. I have iPhone though and it works.

1 Like

I had this happen 4 times in a row on my second battery today. Had a 43 minute flight on first battery, landed, swapped batteries, thought it booted up right, suited up, waked out and hooked up to wing, Get ready to activate and nothing. Dead throttle, did same again, suited up, attempted to activate, dead again. Try2 more times, same results. Pack everything Togo home and was able to get it right by waiting a little longer between first half and second half of connector insertion…

Also downloaded 123SmartBMS app. But could not detect batteries in Bluetooth search. Did some of us get not SmartBMS batteries on the 3rd batch shipped the first week of August?

I can only detect the battery in the app if its charging or plugged into the motor. I also had the battery not working if I plugged it in too fast. Had to go half way wait for the beeps and then go the rest of the way. But the last few times I haven’t had that issue anymore. Not sure why it went away.

You can set the time the BT stays on after activity to like a day if you want, if you look at the setting in the app you can change it.


All of batch 3 has the BT in it.

1 Like

Having problems with one battery. It will take a couple tries to get it to work, then test the throttle by activating it. Spool motor up,deactivate throttle. By the time I go to my wing and get hooked in it shuts off. Did this a couple times yesterday and once today. I swapped batteries and then launched. And then had a terrible landing.

Would that be the sleep timer? What would the password be?

1 Like

Links and stuff in the description.

Default password to change setting is “123456”


Thanks for the info PDWhite. I’m going to check out this timer.