ESC Fast Beep Problem

I tried to fly today, but the throttle controller kept turning on and off. I noticed that the wires were shorted at the at the bottom the controller. I replaced the wire and now one of my motors/esc is beeping quickly after I arm the system. When I give it throttle it will not spin, but the other three work fine. When the disarm, the fast beep continues and the other three resume to their standard slow beep.

From what I can see online about the esc, a fast beep indicates that “the throttle stick is not at the bottom position”. Should I “recalibrate the throttle range”? Do I need to do this for all three esc’s, or just the one? Anyone have instructions on how to do this?

I’m thinking that when the wire shorted, it somehow cleared the memory from the one esc…

You need to power the controller and arm it with the ESCs not powered. Then while holding full throttle power up the ESCs and that will get them into program mode. When you hear beep - beep release the throttle to teach the ESCs throttle range. Probably safest to not have the props on just in case.

How do I power the controller with ESC’s not powered? I tried plugging into the usb at the bottom of the controller with a phone charger, but that did not turn it on.

So I just found a couple of spots on the controller to solder 5V leads to and following GliderPilot’s instructions was able to fix the Fast Beep Problem. Thanks for your help!


Glad you were able to fix this! For future reference it is also possible to power the batch 3 controller with and not worry about ESCs by disconnecting the 4 ESC signal connections to the frame board.