Controller beeps 3 times, no display

I have full weight battery, SP140. Flown a few times in 3 months. Launched on Friday no problem but only a short flight. Came home and charged in overnight. Unplugged normally and when I went to fly it today. It beeps 3 times quickly in succession and no display on the throttle. I tried plugging and plugging differently from the charger thinking it somehow messed the battery up but the battery reads normally when plugged in. Do I have a controller malfunction or battery? What does 3 beeps mean?

Sounds like its a wire connections issue. Make sure your plugs are pugged all the way in.

1 Like

Could be a loose connection in the throttle MY 5 MINUTE FLIGHT - YouTube

I tried resetting the controller and reseating the pins, still didn’t work. I think loose connection in the throttle idea might be spot on. I took a look and couldn’t see anything loose but it is an untrained eye. I tried updating the firmware and the usb didn’t read. I think the throttle controller might be dead. Sent back in and we will see. Maybe I foolishly overlooked something.